How to Solve the Dreaded Firefox Sync “Error while signing in” Problem

Sync LogoSomehow, my Firefox syncs stopped syncing.  I think it had something to do with updating the plugin on one machine but not another.  Anyway, in my attempts to fix this, I got to a point where the secret key was not the same on all the machines.  But when I tried to change it, the change key button was greyed out and I couldn’t type over the (wrong) key.  As a public service, I’m reprinting the solution, found — most obscurely — on a Firefox help thread entitled The article mentions a “secret phrase” but I got a “Firefox Sync Key” instead. Is this the same thing?:

After upgrading to FF 3.6 (now at 3.6.12) , I began getting an error message “! Error while signing in. Please try again” and when I clicked on it, the explanation “Sync encountered an error while connecting: Wrong Sync Key” appeared along with a link to “Preferences” – clicking on this link took me to Sync Preferences > Manage Account. Click on the tab “Sync Key” and the key on that computer is shown – but, you can’t change the Sync Key there (except by generating a new one, which resets the entire account with a new random-generated key, which is not helpful as your other computers can’t generate the same key). How to get all three computers on the same Key? It turns out you have to print the sync key from one of your computers, then trigger the error message on each other computer having a different key. On each other computer, click on Preferences > Manage Account as before, but don’t click on the Sync Key tab; instead click on “Connect” next to your account name. Now you will receive another error message saying “Wrong Sync Key” in red – and beside that, links to “update” and “reset”. Click “update.” (“Reset” merely sends you to generate a new random key.) “Update” takes you to a text box with a blank inviting you to enter a new key: enter the one you copied from the other computer. This box is pre-configured to accept only an alpha-numeric key in blocks of 1-5-5-5-5-5 characters – you cannot enter your choice of text, only a key already generated on another computer. When finished, you should get the message “Your sync keywas successfully changed!” None of this is from FF Help; just trial and error.

Got that?  Here it is in an easier-to-read format:

  1. Print the sync key from one of your computers (or save it to your Dropbox)
  2. Trgger the error message on each other computer having a different key.
  3. On each other computer, click on Preferences > Manage Account as before, but don’t click on the Sync Key tab; instead click on “Connect” next to your account name.
  4. Now you will receive another error message saying “Wrong Sync Key” in red – and beside that, links to “update” and “reset”. Click “update.” (“Reset” merely sends you to generate a new random key.)
  5. “Update” takes you to a text box with a blank inviting you to enter a new key: enter the one you copied from the other computer.

Thank you acbar8!


UPDATE (12/25): While the above does in fact allow you to get all your computers talking to each other again, it doesn’t fully solve the problem: sync will still intermittently fail to connect after working perfectly well. And then later it will work again. This seems to be a bug relating to version 1.6 on the server end. And from the look of things, I don’t think I’m going to be out of the woods until Firefox 4.0 comes out… I advise sticking with version 1.5 on all your machines until this gets worked out. (Note that it’s fairly complex to downgrade from 1.6 to 1.5 as they use different encryption or storage methods. I think you would have to unload the plugin from all the machines, then start a new account with the 1.5 data; otherwise you will end up with a mess, either missing or duplicated bookmarks.)

Maybe it is time to go back to Xmarks, which seems to be back from the dead?

This entry was posted in Software. Bookmark the permalink.

4 Responses to How to Solve the Dreaded Firefox Sync “Error while signing in” Problem

  1. max says:

    haha, well damn dude… thank you for this. you’re like the only post I found regarding this, since it just started happening. the other problem with downgrading sync, btw, is that Firefox complains it *requires* an update to let you sync, which is why I did it in the first place. they don’t F up this bad too often, so I’m willing to overlook it… so long as my data stays intact.

    have you thought about the option of having weave sync to your own server?? I’m looking into it now. cheers.

  2. Soloport says:

    Navigated to root URI of offending host via HTTPS. On arrival, was presented with dread, “Untrusted SSL certificate! Oh no!” page that FF provides. After permanently accepting the certificate exception, the sync problem went away.

    • Robin says:

      How did you navigate to the root URL?

      • Chris Zeh says:

        I also have the problem of Firefox distrusting all HTTPS servers now, seemingly because I’m behind a proxy (Zscaler). I’m pretty much forced to add exceptions for all HTTPS sites with the Zscaler Cert, which of course means I was having sync problems. (Note that this problem wasn’t present in Firefox v12, what happened mozilla?).

        Anyway, it took me awhile to find the “Root URL” in order to add the exceptions for it. I recommend you use the following command in the address bar: “about:config”, then filter for “sync”. There will be a few different websites shown with https, I manually navigated to all of them and added exceptions:
        https://auth.services.mozilla.com/
        https://services.mozilla.com/

        Next you need to add an exception for the actual server you connect to (where your sync account is located). After you add the exceptions above, try to force a new sync. This will update the error logs with the server path.

        Now type “about:sync-log” into the address bar and open the most recent file.

        Find any line that says something like this “WARN Invalid HTTPS certificate encountered!”, and find the URL located in the line before it. Mine was something like this: Caching URLs under storage user base: https://scl2-sync170.services.mozilla.com/1.1/{HASHEDUSERNAMEHERE}

        This worked for me, I’m guessing I won’t always be directed to this particular sever and it might fail again soon. Anyway, your mileage may vary, good luck to you!

        –Chris

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Notify me of followup comments via e-mail. You can also subscribe without commenting.