A Post About Blog Software

Should I upgrade? Change platforms? Once every great while, I think I should either update to a more current version of MovableType from my increasingly archaic 2.64, or attempt the even more herculean task of converting to WordPress. (MT is up to version 5.02!)

Due to the large number of customizations and plugins I've used (not least my dependence on Textile 2 for text formatting, and the somewhat quirky file structure I settled on some week in '03 or '04 when it was Google-friendly), either task would be a real struggle. The whole look of the thing would have to change — which would in fact be the reason to do it. Plus I'd get lots of shiny new toys to play with (aka modern plugins). The version of MT I run now isn't just a dead end, it's a dinosaur in Internet terms. And it has some annoying technical limitations.

If I were going to undertake the upgrade project, I'd either have to do it this summer — a unique moment when I'm not actually supposed to working, so I have the time — or pay someone (who? how to find them?) too much money to do it for me. And given my erratic skills in this area, even I tried to do it, it's not obvious I could import old blog posts into the new system, especially if I switched to WordPress, which works quite differently. The idea of having an “old” and “new” blog isn't all that appealing, but maybe there's no choice. I certainly could set up a new one from scratch and lock down the old one.

Then again, WP is a bigger target for hackers; old versions of MT have some small security through obscurity, and due to their dwindling user base.

Advice from the knowledgeable always welcome. And comments about the aesthetics also appreciated: to my eye, discourse.net's design — if you can dignify it with that name — looks not just crowded but increasingly stogy. Is that:

(a) charming and quaint, or
(b) annoying as hell, or
(c) not important: content is king, never mind the design, or
(d) irrelevant given almost everyone uses the RSS feed to read blogs these days, or
(e) other (explain).

Let me know.

This entry was posted in Discourse.net. Bookmark the permalink.

11 Responses to A Post About Blog Software

  1. Kevin G says:

    (D). So long as the RSS feed is functional, current, and–most importantly–contains the FULL post, it doesn’t matter to me what the blog itself looks like.

  2. mfr24 says:

    wherever you go, we will follow you…..

  3. mfr24 says:

    ((E) by the way (sorry))

  4. Just me says:

    My office blocks many but not all blogs. If you move the discourse.net, the blog the filter at my office may pick it up. Please, please, please, don’t make me read your blog on my blackberry.

  5. Mike says:

    I agree that the design is a bit outdated, but that’s necessarily a bad thing. It looks outdated because most modern designs are more complex than they need to be. Discourse.net is simple and gets the job done.

    Stiil, “should I upgrade,” is a question that haunts a lot of people. If the current systems meets your needs, then, tautologically, there is no need to upgrade. It’s a simple thought that’s often overlooked.

    So, does Discourse.net meet your needs? Is there anything important an upgrade would offer?

  6. Tom D says:

    While one could quibble about the aesthetics, discourse.net is quite functional and easy to use. I might think about upgrading and “cutting the clutter” a bit to streamline.

  7. michael says:

    Just to clarify: Upgrade wouldn’t mean changing the URL. I’d make sure of that, even if I had old blog and new blog; the bifurcation would mean the archives were split, but the front page would just go to the new version.

    But then again, if it ain’t broke…

  8. Kaleberg says:

    The only reason to upgrade is if you really need some new feature, or if some component is on its way out. Otherwise, you blog looks fine. The 26 letter alphabet still seems to serve.

  9. David says:

    I would say start planning to move. Even if the current site fits your needs and you’re not unhappy with it, sooner rather than later something will break on MT v.2.64 and you’ll have to migrate under the stress of a broken site. The /only/ reason I say this is because your particular isntall of MT is so long in the tooth; otherwise I’d say ‘if it ain’t broke…’ .

    I would be pretty surprised if WP (or similar) couldn’t import your current posts into a new site.

  10. John Flood says:

    As one who is unsure whether to stay with Blogger, as that’s where I started, or move to a WT site attached to my website, I understand your qualms. I end up doing both. Path dependency comes to mind…

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Notify me of followup comments via e-mail. You can also subscribe without commenting.